{"cve":"CVE-2017-18885","nvd":{"published":"2020-06-19T19:15:10.420","modified":"2026-06-17T01:13:46.087","status":"Modified","description":"An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2. It allows attackers to gain privileges by accessing unintended API endpoints on a user's behalf.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-269"],"references":["https://mattermost.com/security-updates/","https://mattermost.com/security-updates/"],"products":["mattermost:mattermost_server"],"source":"nvd","synced_at":"2026-10-19T21:05:42.039641217+00:00"},"epss":{"cve":"CVE-2017-18885","score":0.01184,"percentile":0.67809,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-g78f-6xq7-rrhq","url":"https://osv.dev/vulnerability/GHSA-g78f-6xq7-rrhq","summary":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials","modified":"2026-01-06T23:41:17.979183Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=4.2.0-rc1 <4.2.1"],"fixed":["4.2.1"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=4.3.0-rc1 <4.3.0"],"fixed":["4.3.0"]}]},{"id":"GO-2025-4200","url":"https://osv.dev/vulnerability/GO-2025-4200","summary":"Mattermost Server allows attackers to gain privileges by accessing unintended API endpoints with users' credentials in github.com/mattermost/mattermost-server","modified":"2026-03-03T04:57:46.399048Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<4.1.2+incompatible",">=4.2.0-rc1+incompatible <4.2.1+incompatible",">=4.3.0-rc1+incompatible <4.3.0+incompatible"],"fixed":["4.1.2+incompatible","4.2.1+incompatible","4.3.0+incompatible"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}