{"cve":"CVE-2017-18883","nvd":{"published":"2020-06-19T19:15:10.310","modified":"2026-06-17T01:13:45.420","status":"Modified","description":"An issue was discovered in Mattermost Server before 4.3.0, 4.2.1, and 4.1.2, when serving as an OAuth 2.0 Service Provider. There is low entropy for authorization data.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","score":9.1},"cwes":["CWE-331"],"references":["https://mattermost.com/security-updates/","https://mattermost.com/security-updates/"],"products":["mattermost:mattermost_server"],"source":"nvd","synced_at":"2026-10-19T21:05:42.039641217+00:00"},"epss":{"cve":"CVE-2017-18883","score":0.01134,"percentile":0.66493,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w8cc-3h7q-jhc3","url":"https://osv.dev/vulnerability/GHSA-w8cc-3h7q-jhc3","summary":"Mattermost Server has low entropy for authorization data as an OAuth 2.0 Service Provider","modified":"2025-12-09T17:57:50.668315Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<4.1.2"],"fixed":["4.1.2"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=4.2.0-rc1 <4.2.1"],"fixed":["4.2.1"]},{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":[">=4.3.0-rc1 <4.3.0"],"fixed":["4.3.0"]}]},{"id":"GO-2025-4198","url":"https://osv.dev/vulnerability/GO-2025-4198","summary":"Mattermost Server has low entropy for authorization data as an OAuth 2.0 Service Provider in github.com/mattermost/mattermost-server","modified":"2026-03-03T04:57:45.099177Z","packages":[{"ecosystem":"Go","name":"github.com/mattermost/mattermost-server","purl":"pkg:golang/github.com/mattermost/mattermost-server","ranges":["<4.1.2+incompatible",">=4.2.0-rc1+incompatible <4.2.1+incompatible",">=4.3.0-rc1+incompatible <4.3.0+incompatible"],"fixed":["4.1.2+incompatible","4.2.1+incompatible","4.3.0+incompatible"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}