{"cve":"CVE-2017-17718","nvd":{"published":"2017-12-17T21:29:00.267","modified":"2026-06-17T01:11:32.243","status":"Modified","description":"The Net::LDAP (aka net-ldap) gem before 0.16.0 for Ruby has Missing SSL Certificate Validation.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","score":5.9},"cwes":["CWE-295"],"references":["http://openwall.com/lists/oss-security/2017/12/17/10","https://github.com/ruby-ldap/ruby-net-ldap/issues/258","https://github.com/ruby-ldap/ruby-net-ldap/pull/279","http://openwall.com/lists/oss-security/2017/12/17/10","https://github.com/ruby-ldap/ruby-net-ldap/issues/258"],"products":["net-ldap_project:net-ldap"],"source":"nvd","synced_at":"2026-10-19T20:47:56.471723566+00:00"},"epss":{"cve":"CVE-2017-17718","score":0.01348,"percentile":0.7148,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m7p8-9w66-9frm","url":"https://osv.dev/vulnerability/GHSA-m7p8-9w66-9frm","summary":"net-ldap Improper Certificate Validation vulnerability","modified":"2023-11-08T03:59:14.647519Z","packages":[{"ecosystem":"RubyGems","name":"net-ldap","purl":"pkg:gem/net-ldap","ranges":["<0.16.0"],"fixed":["0.16.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}