{"cve":"CVE-2017-16042","nvd":{"published":"2018-06-04T19:29:02.100","modified":"2026-06-17T01:08:42.210","status":"Modified","description":"Growl adds growl notification support to nodejs. Growl before 1.10.2 does not properly sanitize input before passing it to exec, allowing for arbitrary command execution.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-78","CWE-94"],"references":["https://github.com/tj/node-growl/issues/60","https://github.com/tj/node-growl/pull/61","https://nodesecurity.io/advisories/146","https://github.com/tj/node-growl/issues/60","https://github.com/tj/node-growl/pull/61"],"products":["growl_project:growl"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2017-16042","score":0.04581,"percentile":0.91635,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qh2h-chj9-jffq","url":"https://osv.dev/vulnerability/GHSA-qh2h-chj9-jffq","summary":"Growl before 1.10.0 vulnerable to Command Injection","modified":"2023-11-08T03:59:01.241655Z","packages":[{"ecosystem":"npm","name":"growl","purl":"pkg:npm/growl","ranges":["<1.10.0"],"fixed":["1.10.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}