{"cve":"CVE-2017-16013","nvd":{"published":"2018-06-04T19:29:00.880","modified":"2026-06-17T01:08:38.483","status":"Modified","description":"hapi is a web and services application framework. When hapi >= 15.0.0 <= 16.1.0 encounters a malformed `accept-encoding` header an uncaught exception is thrown. This may cause hapi to crash or to hang the client connection until the timeout period is reached.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-20","CWE-400"],"references":["https://github.com/hapijs/hapi/issues/3466","https://nodesecurity.io/advisories/335","https://github.com/hapijs/hapi/issues/3466","https://nodesecurity.io/advisories/335"],"products":["hapijs:hapi"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2017-16013","score":0.01559,"percentile":0.75226,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cqjg-whmm-8gv6","url":"https://osv.dev/vulnerability/GHSA-cqjg-whmm-8gv6","summary":"Denial of Service via malformed accept-encoding header in hapi","modified":"2023-11-08T03:58:59.647182Z","packages":[{"ecosystem":"npm","name":"hapi","purl":"pkg:npm/hapi","ranges":[">=15.0.0 <16.1.1"],"fixed":["16.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}