{"cve":"CVE-2017-16008","nvd":{"published":"2018-06-04T19:29:00.677","modified":"2026-06-17T01:08:38.140","status":"Modified","description":"i18next is a language translation framework. Because of how the interpolation is implemented, making replacements from the dictionary one at a time, untrusted user input can use the name of one of the dictionary keys to inject script into the browser. This affects i18next <=1.10.2.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://github.com/i18next/i18next/pull/443","https://nodesecurity.io/advisories/325","https://github.com/i18next/i18next/pull/443","https://nodesecurity.io/advisories/325"],"products":["i18next:i18next"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2017-16008","score":0.00849,"percentile":0.58152,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f89g-whpf-6q9m","url":"https://osv.dev/vulnerability/GHSA-f89g-whpf-6q9m","summary":"Cross-Site Scripting in i18next","modified":"2023-11-08T03:58:59.466803Z","packages":[{"ecosystem":"npm","name":"i18next","purl":"pkg:npm/i18next","ranges":["<1.10.3"],"fixed":["1.10.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}