{"cve":"CVE-2017-15708","nvd":{"published":"2017-12-11T15:29:00.237","modified":"2026-06-17T01:08:08.210","status":"Modified","description":"In Apache Synapse, by default no authentication is required for Java Remote Method Invocation (RMI). So Apache Synapse 3.0.1 or all previous releases (3.0.0, 2.1.0, 2.0.0, 1.2, 1.1.2, 1.1.1) allows remote code execution attacks that can be performed by injecting specially crafted serialized objects. And the presence of Apache Commons Collections 3.2.1 (commons-collections-3.2.1.jar) or previous versions in Synapse distribution makes this exploitable. To mitigate the issue, we need to limit RMI access to trusted users only. Further upgrading to 3.0.1 version will eliminate the risk of having said Commons Collection version. In Synapse 3.0.1, Commons Collection has been updated to 3.2.2 version.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-74"],"references":["http://www.securityfocus.com/bid/102154","https://lists.apache.org/thread.html/77f2accf240d25d91b47033e2f8ebec84ffbc6e6627112b2f98b66c9%40%3Cdev.synapse.apache.org%3E","https://lists.apache.org/thread.html/r0fb289cd38c915b9a13a3376134f96222dd9100f1ef66b41631865c6%40%3Ccommits.doris.apache.org%3E","https://security.gentoo.org/glsa/202107-37","https://www.oracle.com/security-alerts/cpujan2020.html"],"products":["apache:synapse","oracle:financial_services_market_risk_measurement_and_management","oracle:peoplesoft_enterprise_peopletools"],"source":"nvd","synced_at":"2026-10-19T20:47:56.471723566+00:00"},"epss":{"cve":"CVE-2017-15708","score":0.1788,"percentile":0.97176,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p694-23q3-rvrc","url":"https://osv.dev/vulnerability/GHSA-p694-23q3-rvrc","summary":"Remote Code Execution in Apache Synapse","modified":"2023-11-08T03:58:58.363047Z","packages":[{"ecosystem":"Maven","name":"org.apache.synapse:synapse-core","purl":"pkg:maven/org.apache.synapse/synapse-core","ranges":["<3.0.1"],"fixed":["3.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}