{"cve":"CVE-2017-14033","nvd":{"published":"2017-09-19T17:29:00.327","modified":"2026-06-17T01:05:28.650","status":"Modified","description":"The decode method in the OpenSSL::ASN1 module in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows attackers to cause a denial of service (interpreter crash) via a crafted string.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-119"],"references":["http://www.securityfocus.com/bid/100868","http://www.securitytracker.com/id/1039363","http://www.securitytracker.com/id/1042004","https://access.redhat.com/errata/RHSA-2018:0378","https://access.redhat.com/errata/RHSA-2018:0583"],"products":["ruby-lang:ruby"],"source":"nvd","synced_at":"2026-10-19T20:46:01.145313090+00:00"},"epss":{"cve":"CVE-2017-14033","score":0.07734,"percentile":0.94624,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-v6rp-3r3v-hf4p","url":"https://osv.dev/vulnerability/GHSA-v6rp-3r3v-hf4p","summary":"Ruby OpenSSL DoS Vulnerability","modified":"2024-02-16T08:21:15.875104Z","packages":[{"ecosystem":"RubyGems","name":"openssl","purl":"pkg:gem/openssl","ranges":["<2.0.0"],"fixed":["2.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}