{"cve":"CVE-2017-1000479","nvd":{"published":"2018-01-03T18:29:00.323","modified":"2026-06-17T00:59:14.570","status":"Modified","description":"pfSense versions 2.4.1 and lower are vulnerable to clickjacking attacks in the CSRF error page resulting in privileged execution of arbitrary code, because the error detection occurs before an X-Frame-Options header is set. This is fixed in 2.4.2-RELEASE. OPNsense, a 2015 fork of pfSense, was not vulnerable since version 16.1.16 released on June 06, 2016. The unprotected web form was removed from the code during an internal security audit under \"possibly insecure\" suspicions.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","score":8.8},"cwes":["CWE-352"],"references":["http://www.openwall.com/lists/oss-security/2017/11/22/7","https://doc.pfsense.org/index.php/2.4.2_New_Features_and_Changes","https://github.com/opnsense/core/commit/d218b225","https://github.com/pfsense/pfsense/commit/386d89b07","https://www.netgate.com/blog/pfsense-2-4-2-release-p1-and-2-3-5-release-p1-now-available.html"],"products":["netgate:pfsense","opnsense_project:opnsense"],"source":"nvd","synced_at":"2026-10-19T20:47:56.471723566+00:00"},"epss":{"cve":"CVE-2017-1000479","score":0.31701,"percentile":0.98296,"date":"2026-10-31"},"kev":null,"osv":[],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}