{"cve":"CVE-2017-1000397","nvd":{"published":"2018-01-26T02:29:00.970","modified":"2026-06-17T00:59:05.950","status":"Modified","description":"Jenkins Maven Plugin 2.17 and earlier bundled a version of the commons-httpclient library with the vulnerability CVE-2012-6153 that incorrectly verified SSL certificates, making it susceptible to man-in-the-middle attacks. Maven Plugin 3.0 no longer has a dependency on commons-httpclient.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N","score":5.9},"cwes":["CWE-20"],"references":["https://jenkins.io/security/advisory/2017-10-11/","https://jenkins.io/security/advisory/2017-10-11/"],"products":["jenkins:maven"],"source":"nvd","synced_at":"2026-10-19T20:48:34.567387330+00:00"},"epss":{"cve":"CVE-2017-1000397","score":0.00488,"percentile":0.42032,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qhxw-54m9-6wwc","url":"https://osv.dev/vulnerability/GHSA-qhxw-54m9-6wwc","summary":"MitM on Jenkins Maven Plugin","modified":"2024-02-22T05:33:37.731519Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.main:maven-plugin","purl":"pkg:maven/org.jenkins-ci.main/maven-plugin","ranges":["<3.0"],"fixed":["3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}