{"cve":"CVE-2017-1000388","nvd":{"published":"2018-01-26T02:29:00.377","modified":"2026-06-17T00:59:04.973","status":"Modified","description":"Jenkins Dependency Graph Viewer plugin 0.12 and earlier did not perform permission checks for the API endpoint that modifies the dependency graph, allowing anyone with Overall/Read permission to modify this data.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","score":4.3},"cwes":["CWE-862"],"references":["https://jenkins.io/security/advisory/2017-10-23/","https://jenkins.io/security/advisory/2017-10-23/"],"products":["jenkins:dependency_graph_viewer"],"source":"nvd","synced_at":"2026-10-19T20:48:34.567387330+00:00"},"epss":{"cve":"CVE-2017-1000388","score":0.0063,"percentile":0.50214,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-vhh3-mvc4-hhq6","url":"https://osv.dev/vulnerability/GHSA-vhh3-mvc4-hhq6","summary":"Jenkins Dependency Graph Viewer plugin vulnerable to missing permission checks","modified":"2024-02-18T05:33:10.031389Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:depgraph-view","purl":"pkg:maven/org.jenkins-ci.plugins/depgraph-view","ranges":["<0.13"],"fixed":["0.13"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}