{"cve":"CVE-2017-1000228","nvd":{"published":"2017-11-17T03:29:00.377","modified":"2026-06-17T00:58:56.620","status":"Modified","description":"nodejs ejs versions older than 2.5.3 is vulnerable to remote code execution due to weak input validation in ejs.renderFile() function","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-20"],"references":["http://www.securityfocus.com/bid/101897","https://snyk.io/vuln/npm:ejs:20161128","http://www.securityfocus.com/bid/101897","https://snyk.io/vuln/npm:ejs:20161128"],"products":["ejs:ejs"],"source":"nvd","synced_at":"2026-10-19T20:47:01.408438353+00:00"},"epss":{"cve":"CVE-2017-1000228","score":0.0638,"percentile":0.93664,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-3w5v-p54c-f74x","url":"https://osv.dev/vulnerability/GHSA-3w5v-p54c-f74x","summary":"ejs is vulnerable to remote code execution due to weak input validation","modified":"2023-11-08T03:58:44.472757Z","packages":[{"ecosystem":"npm","name":"ejs","purl":"pkg:npm/ejs","ranges":["<2.5.5"],"fixed":["2.5.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}