{"cve":"CVE-2017-1000188","nvd":{"published":"2017-11-17T03:29:00.267","modified":"2026-06-17T00:58:52.723","status":"Modified","description":"nodejs ejs version older than 2.5.5 is vulnerable to a Cross-site-scripting in the ejs.renderFile() resulting in code injection","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.securityfocus.com/bid/101889","https://github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f","http://www.securityfocus.com/bid/101889","https://github.com/mde/ejs/commit/49264e0037e313a0a3e033450b5c184112516d8f"],"products":["ejs:ejs"],"source":"nvd","synced_at":"2026-10-19T20:47:01.408438353+00:00"},"epss":{"cve":"CVE-2017-1000188","score":0.01233,"percentile":0.69018,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-hwcf-pp87-7x6p","url":"https://osv.dev/vulnerability/GHSA-hwcf-pp87-7x6p","summary":"mde ejs vulnerable to XSS","modified":"2023-11-08T03:58:43.740712Z","packages":[{"ecosystem":"npm","name":"ejs","purl":"pkg:npm/ejs","ranges":["<2.5.5"],"fixed":["2.5.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}