{"cve":"CVE-2017-0906","nvd":{"published":"2017-11-13T17:29:00.457","modified":"2026-06-17T00:58:30.330","status":"Modified","description":"The Recurly Client Python Library before 2.0.5, 2.1.16, 2.2.22, 2.3.1, 2.4.5, 2.5.1, 2.6.2 is vulnerable to a Server-Side Request Forgery vulnerability in the \"Resource.get\" method that could result in compromise of API keys or other critical resources.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-918"],"references":["https://dev.recurly.com/page/python-updates","https://github.com/recurly/recurly-client-python/commit/049c74699ce93cf126feff06d632ea63fba36742","https://hackerone.com/reports/288635","https://dev.recurly.com/page/python-updates","https://github.com/recurly/recurly-client-python/commit/049c74699ce93cf126feff06d632ea63fba36742"],"products":["recurly:recurly_client_python"],"source":"nvd","synced_at":"2026-10-19T20:47:01.408438353+00:00"},"epss":{"cve":"CVE-2017-0906","score":0.02616,"percentile":0.85439,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-38rv-5jqc-m2cv","url":"https://osv.dev/vulnerability/GHSA-38rv-5jqc-m2cv","summary":"Recurly vulnerable to SSRF","modified":"2024-10-26T18:50:44.966235Z","packages":[{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.6.0 <2.6.2"],"fixed":["2.6.2"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.5.0 <2.5.1"],"fixed":["2.5.1"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.4.0 <2.4.5"],"fixed":["2.4.5"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.3.0 <2.3.1"],"fixed":["2.3.1"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.2.0 <2.2.22"],"fixed":["2.2.22"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.1.0 <2.1.16"],"fixed":["2.1.16"]},{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":["<2.0.5"],"fixed":["2.0.5"]}]},{"id":"PYSEC-2017-68","url":"https://osv.dev/vulnerability/PYSEC-2017-68","summary":"","modified":"2023-11-08T03:58:40.982643Z","packages":[{"ecosystem":"PyPI","name":"recurly","purl":"pkg:pypi/recurly","ranges":[">=2.0 <2.0.5",">=2.1 <2.1.16",">=2.2 <2.2.22",">=2.3 <2.3.1",">=2.4 <2.4.5",">=2.5 <2.5.1",">=2.6 <2.6.2"],"fixed":["2.0.5","2.1.16","2.2.22","2.3.1","2.4.5","2.5.1","2.6.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}