{"cve":"CVE-2016-7954","nvd":{"published":"2016-12-22T22:59:00.123","modified":"2026-06-17T00:53:49.280","status":"Modified","description":"Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source.  NOTE: this might overlap CVE-2013-0334.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94"],"references":["http://collectiveidea.com/blog/archives/2016/10/06/bundlers-multiple-source-security-vulnerability/","http://www.openwall.com/lists/oss-security/2016/10/04/5","http://www.openwall.com/lists/oss-security/2016/10/04/7","http://www.openwall.com/lists/oss-security/2016/10/05/3","http://www.securityfocus.com/bid/93423"],"products":["bundler:bundler"],"source":"nvd","synced_at":"2026-10-19T20:41:25.729257544+00:00"},"epss":{"cve":"CVE-2016-7954","score":0.08821,"percentile":0.95189,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-jvgm-pfqv-887x","url":"https://osv.dev/vulnerability/GHSA-jvgm-pfqv-887x","summary":"Bundler allows attacker to inject arbitrary code via secondary Gem source","modified":"2025-04-14T22:27:57.972251Z","packages":[{"ecosystem":"RubyGems","name":"bundler","purl":"pkg:gem/bundler","ranges":[">=1.0.0 <2.0.0"],"fixed":["2.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}