{"cve":"CVE-2016-5697","nvd":{"published":"2017-01-23T21:59:01.707","modified":"2026-06-17T00:49:53.460","status":"Modified","description":"Ruby-saml before 1.3.0 allows attackers to perform XML signature wrapping attacks via unspecified vectors.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-91"],"references":["http://www.openwall.com/lists/oss-security/2016/06/24/3","http://www.openwall.com/lists/oss-security/2016/06/24/3"],"products":["onelogin:ruby-saml"],"source":"nvd","synced_at":"2026-10-19T20:41:25.729257544+00:00"},"epss":{"cve":"CVE-2016-5697","score":0.01208,"percentile":0.68386,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-36p7-xjw8-h6f2","url":"https://osv.dev/vulnerability/GHSA-36p7-xjw8-h6f2","summary":"Ruby-saml allows attackers to perform XML signature wrapping attacks ","modified":"2024-02-16T08:17:29.100536Z","packages":[{"ecosystem":"RubyGems","name":"ruby-saml","purl":"pkg:gem/ruby-saml","ranges":["<1.3.0"],"fixed":["1.3.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}