{"cve":"CVE-2016-5682","nvd":{"published":"2017-04-10T03:59:02.077","modified":"2026-06-17T00:49:52.030","status":"Modified","description":"Swagger-UI before 2.2.1 has XSS via the Default field in the Definitions section.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://community.rapid7.com/community/infosec/blog/2016/09/02/r7-2016-19-persistent-xss-via-unescaped-parameters-in-swagger-ui","https://community.rapid7.com/community/infosec/blog/2016/09/02/r7-2016-19-persistent-xss-via-unescaped-parameters-in-swagger-ui"],"products":["smartbear:swagger-ui"],"source":"nvd","synced_at":"2026-10-19T20:42:09.859288039+00:00"},"epss":{"cve":"CVE-2016-5682","score":0.01028,"percentile":0.63674,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-p239-93f7-h6xf","url":"https://osv.dev/vulnerability/GHSA-p239-93f7-h6xf","summary":"Cross-Site Scripting in swagger-ui","modified":"2023-11-08T03:58:31.570959Z","packages":[{"ecosystem":"npm","name":"swagger-ui","purl":"pkg:npm/swagger-ui","ranges":["<2.2.1"],"fixed":["2.2.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}