{"cve":"CVE-2016-3102","nvd":{"published":"2017-02-09T15:59:01.003","modified":"2026-06-17T00:44:58.543","status":"Modified","description":"The Script Security plugin before 1.18.1 in Jenkins might allow remote attackers to bypass a Groovy sandbox protection mechanism via a plugin that performs (1) direct field access or (2) get/set array operations.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","score":7.3},"cwes":["CWE-254"],"references":["https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-04-11","https://wiki.jenkins-ci.org/display/SECURITY/Jenkins+Security+Advisory+2016-04-11"],"products":["jenkins:script_security"],"source":"nvd","synced_at":"2026-10-19T20:41:54.846948762+00:00"},"epss":{"cve":"CVE-2016-3102","score":0.01769,"percentile":0.78132,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-xgjx-96v4-mqxx","url":"https://osv.dev/vulnerability/GHSA-xgjx-96v4-mqxx","summary":"Jenkins Script Security Plugin allows for Bypass of Groovy Sandbox Protection","modified":"2025-03-13T19:28:47.181144Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:script-security","purl":"pkg:maven/org.jenkins-ci.plugins/script-security","ranges":["<1.18.1"],"fixed":["1.18.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}