{"cve":"CVE-2016-11086","nvd":{"published":"2020-09-24T20:15:12.257","modified":"2026-06-17T00:40:58.267","status":"Modified","description":"lib/oauth/consumer.rb in the oauth-ruby gem through 0.5.4 for Ruby does not verify server X.509 certificates if a certificate bundle cannot be found, which allows man-in-the-middle attackers to spoof servers and obtain sensitive information.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","score":7.4},"cwes":["CWE-295"],"references":["https://github.com/oauth-xx/oauth-ruby/issues/137","https://github.com/oauth-xx/oauth-ruby/issues/137"],"products":["oauth-ruby_project:oauth-ruby"],"source":"nvd","synced_at":"2026-10-19T21:09:53.489947993+00:00"},"epss":{"cve":"CVE-2016-11086","score":0.00862,"percentile":0.58562,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7359-3c6r-hfc2","url":"https://osv.dev/vulnerability/GHSA-7359-3c6r-hfc2","summary":"Improper Certificate Validation in oauth ruby gem","modified":"2023-11-08T03:58:21.880410Z","packages":[{"ecosystem":"RubyGems","name":"oauth","purl":"pkg:gem/oauth","ranges":["<0.5.5"],"fixed":["0.5.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}