{"cve":"CVE-2016-10735","nvd":{"published":"2019-01-09T05:29:00.883","modified":"2026-06-17T00:40:15.560","status":"Modified","description":"In Bootstrap 3.x before 3.4.0 and 4.x-beta before 4.0.0-beta.2, XSS is possible in the data-target attribute, a different vulnerability than CVE-2018-14041.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["https://access.redhat.com/errata/RHBA-2019:1076","https://access.redhat.com/errata/RHBA-2019:1570","https://access.redhat.com/errata/RHSA-2019:1456","https://access.redhat.com/errata/RHSA-2019:3023","https://access.redhat.com/errata/RHSA-2020:0132"],"products":["getbootstrap:bootstrap"],"source":"nvd","synced_at":"2026-10-19T20:54:36.112582389+00:00"},"epss":{"cve":"CVE-2016-10735","score":0.0404,"percentile":0.90618,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4p24-vmcr-4gqj","url":"https://osv.dev/vulnerability/GHSA-4p24-vmcr-4gqj","summary":"Bootstrap Cross-site Scripting vulnerability","modified":"2026-09-10T03:47:46.216378687Z","packages":[{"ecosystem":"npm","name":"bootstrap","purl":"pkg:npm/bootstrap","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"npm","name":"bootstrap","purl":"pkg:npm/bootstrap","ranges":[">=4.0.0-beta <4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]},{"ecosystem":"Maven","name":"org.webjars:bootstrap","purl":"pkg:maven/org.webjars/bootstrap","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Maven","name":"org.webjars:bootstrap","purl":"pkg:maven/org.webjars/bootstrap","ranges":[">=4.0.0-beta <4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]},{"ecosystem":"RubyGems","name":"bootstrap","purl":"pkg:gem/bootstrap","ranges":["<4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]},{"ecosystem":"Packagist","name":"twbs/bootstrap","purl":"pkg:composer/twbs/bootstrap","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"Packagist","name":"twbs/bootstrap","purl":"pkg:composer/twbs/bootstrap","ranges":[">=4.0.0-beta <4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]},{"ecosystem":"NuGet","name":"bootstrap","purl":"pkg:nuget/bootstrap","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"NuGet","name":"bootstrap","purl":"pkg:nuget/bootstrap","ranges":[">=4.0.0-beta <4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]},{"ecosystem":"npm","name":"bootstrap-sass","purl":"pkg:npm/bootstrap-sass","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"RubyGems","name":"bootstrap-sass","purl":"pkg:gem/bootstrap-sass","ranges":[">=2.0.4 <3.4.0"],"fixed":["3.4.0"]},{"ecosystem":"NuGet","name":"bootstrap.sass","purl":"pkg:nuget/bootstrap.sass","ranges":[">=4.0.0-beta <4.0.0-beta.2"],"fixed":["4.0.0-beta.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}