{"cve":"CVE-2016-10546","nvd":{"published":"2018-05-31T20:29:01.690","modified":"2026-06-17T00:39:54.773","status":"Modified","description":"An arbitrary code injection vector was found in PouchDB 6.0.4 and lesser via the map/reduce functions used in PouchDB temporary views and design documents. The code execution engine for this branch is not properly sandboxed and may be used to run arbitrary JavaScript as well as system commands.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94"],"references":["https://nodesecurity.io/advisories/143","https://nodesecurity.io/advisories/143"],"products":["pouchdb:pouchdb"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2016-10546","score":0.02565,"percentile":0.85121,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-cgqv-x5cx-xvqh","url":"https://osv.dev/vulnerability/GHSA-cgqv-x5cx-xvqh","summary":"Arbitrary Code Injection in pouchdb","modified":"2023-11-08T03:58:11.764985Z","packages":[{"ecosystem":"npm","name":"pouchdb","purl":"pkg:npm/pouchdb","ranges":["<6.0.5"],"fixed":["6.0.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}