{"cve":"CVE-2016-10541","nvd":{"published":"2018-05-31T20:29:01.503","modified":"2026-06-17T00:39:54.340","status":"Modified","description":"The npm module \"shell-quote\" 1.6.0 and earlier cannot correctly escape \">\" and \"<\" operator used for redirection in shell. Applications that depend on shell-quote may also be vulnerable. A malicious user could perform code injection.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-94","CWE-78"],"references":["https://github.com/advisories/GHSA-qg8p-v9q4-gh34","https://nodesecurity.io/advisories/117","https://github.com/advisories/GHSA-qg8p-v9q4-gh34","https://nodesecurity.io/advisories/117"],"products":["shell-quote_project:shell-quote"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2016-10541","score":0.02216,"percentile":0.8264,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qg8p-v9q4-gh34","url":"https://osv.dev/vulnerability/GHSA-qg8p-v9q4-gh34","summary":"Potential Command Injection in shell-quote","modified":"2026-09-10T03:48:38.913825182Z","packages":[{"ecosystem":"npm","name":"shell-quote","purl":"pkg:npm/shell-quote","ranges":["<1.6.1"],"fixed":["1.6.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}