{"cve":"CVE-2016-10539","nvd":{"published":"2018-05-31T20:29:01.407","modified":"2026-06-17T00:39:54.123","status":"Modified","description":"negotiator is an HTTP content negotiator for Node.js and is used by many modules and frameworks including Express and Koa. The header for \"Accept-Language\", when parsed by negotiator 0.6.0 and earlier is vulnerable to Regular Expression Denial of Service via a specially crafted string.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-20","CWE-400"],"references":["https://nodesecurity.io/advisories/106","https://nodesecurity.io/advisories/106"],"products":["negotiator_project:negotiator"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2016-10539","score":0.01389,"percentile":0.72308,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-7mc5-chhp-fmc3","url":"https://osv.dev/vulnerability/GHSA-7mc5-chhp-fmc3","summary":"Regular Expression Denial of Service in negotiator","modified":"2023-11-08T03:58:11.394437Z","packages":[{"ecosystem":"npm","name":"negotiator","purl":"pkg:npm/negotiator","ranges":["<0.6.1"],"fixed":["0.6.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}