{"cve":"CVE-2016-10193","nvd":{"published":"2017-03-03T15:59:00.367","modified":"2026-06-17T00:39:15.233","status":"Modified","description":"The espeak-ruby gem before 1.0.3 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a string to the speak, save, bytes or bytes_wav method in lib/espeak/speech.rb.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-284"],"references":["http://www.openwall.com/lists/oss-security/2017/01/31/14","http://www.openwall.com/lists/oss-security/2017/02/02/5","https://github.com/dejan/espeak-ruby/issues/7","http://www.openwall.com/lists/oss-security/2017/01/31/14","http://www.openwall.com/lists/oss-security/2017/02/02/5"],"products":["espeak-ruby_project:espeak-ruby"],"source":"nvd","synced_at":"2026-10-19T20:41:54.846948762+00:00"},"epss":{"cve":"CVE-2016-10193","score":0.02448,"percentile":0.84369,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4jm3-pfpf-h54p","url":"https://osv.dev/vulnerability/GHSA-4jm3-pfpf-h54p","summary":"espeak-ruby allows arbitrary command execution","modified":"2024-02-16T08:24:31.339878Z","packages":[{"ecosystem":"RubyGems","name":"espeak-ruby","purl":"pkg:gem/espeak-ruby","ranges":["<1.0.3"],"fixed":["1.0.3"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}