{"cve":"CVE-2015-8861","nvd":{"published":"2017-01-23T21:59:00.720","modified":"2026-06-17T00:35:23.187","status":"Modified","description":"The handlebars package before 4.0.0 for Node.js allows remote attackers to conduct cross-site scripting (XSS) attacks by leveraging a template with an attribute that is not quoted.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2016/04/20/11","http://www.securityfocus.com/bid/96434","https://www.sourceclear.com/blog/handlebars_vulnerability_research_findings/","https://www.tenable.com/security/tns-2016-18","http://www.openwall.com/lists/oss-security/2016/04/20/11"],"products":["handlebars.js_project:handlebars.js"],"source":"nvd","synced_at":"2026-10-19T20:41:25.729257544+00:00"},"epss":{"cve":"CVE-2015-8861","score":0.02612,"percentile":0.85416,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-9prh-257w-9277","url":"https://osv.dev/vulnerability/GHSA-9prh-257w-9277","summary":"Cross-Site Scripting in handlebars","modified":"2026-09-10T03:47:03.242095655Z","packages":[{"ecosystem":"npm","name":"handlebars","purl":"pkg:npm/handlebars","ranges":["<4.0.0"],"fixed":["4.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}