{"cve":"CVE-2015-7314","nvd":{"published":"2015-10-06T01:59:32.500","modified":"2026-06-17T00:32:14.520","status":"Modified","description":"The Precious module in gollum before 4.0.1 allows remote attackers to read arbitrary files by leveraging the lack of a certain temporary-file check.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-200"],"references":["http://jvn.jp/en/jp/JVN27548431/index.html","http://jvndb.jvn.jp/jvndb/JVNDB-2015-000149","http://www.openwall.com/lists/oss-security/2015/09/22/12","https://github.com/gollum/gollum/commit/ce68a88293ce3b18c261312392ad33a88bb69ea1","https://github.com/gollum/gollum/issues/1070"],"products":["gollum_project:gollum"],"source":"nvd","synced_at":"2026-10-19T20:37:45.466985407+00:00"},"epss":{"cve":"CVE-2015-7314","score":0.01876,"percentile":0.79417,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m2q3-53fq-7h66","url":"https://osv.dev/vulnerability/GHSA-m2q3-53fq-7h66","summary":"Gollum Exposure of Sensitive Information","modified":"2024-12-05T05:29:49.816459Z","packages":[{"ecosystem":"RubyGems","name":"gollum","purl":"pkg:gem/gollum","ranges":["<4.0.1"],"fixed":["4.0.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}