{"cve":"CVE-2015-5169","nvd":{"published":"2017-09-25T21:29:00.303","modified":"2026-06-17T00:28:36.103","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in Apache Struts before 2.3.20.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://jvn.jp/en/jp/JVN95989300/index.html","http://jvndb.jvn.jp/en/contents/2015/JVNDB-2015-000125.html","http://www.securityfocus.com/bid/76625","https://bugzilla.redhat.com/show_bug.cgi?id=1260087","https://security.netapp.com/advisory/ntap-20180629-0003/"],"products":["apache:struts"],"source":"nvd","synced_at":"2026-10-19T20:46:01.145313090+00:00"},"epss":{"cve":"CVE-2015-5169","score":0.07533,"percentile":0.94507,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-vwhv-j36g-5rm8","url":"https://osv.dev/vulnerability/GHSA-vwhv-j36g-5rm8","summary":"Cross-site Scripting in Apache Struts","modified":"2024-02-18T05:32:35.719242Z","packages":[{"ecosystem":"Maven","name":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","ranges":["<2.3.20"],"fixed":["2.3.20"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}