{"cve":"CVE-2015-20108","nvd":{"published":"2023-05-27T19:15:09.043","modified":"2026-06-17T00:23:24.220","status":"Modified","description":"xml_security.rb in the ruby-saml gem before 1.0.0 for Ruby allows XPath injection and code execution because prepared statements are not used.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","score":9.8},"cwes":["CWE-77"],"references":["https://github.com/SAML-Toolkits/ruby-saml/commit/9853651b96b99653ea8627d757d46bfe62ab6448","https://github.com/SAML-Toolkits/ruby-saml/compare/v0.9.2...v1.0.0","https://github.com/SAML-Toolkits/ruby-saml/pull/225","https://github.com/rubysec/ruby-advisory-db/blob/master/gems/ruby-saml/OSVDB-124991.yml","https://security.netapp.com/advisory/ntap-20230703-0003/"],"products":["onelogin:ruby-saml"],"source":"nvd","synced_at":"2026-10-19T21:38:24.161619714+00:00"},"epss":{"cve":"CVE-2015-20108","score":0.01332,"percentile":0.71105,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-r364-2pj4-pf7f","url":"https://osv.dev/vulnerability/GHSA-r364-2pj4-pf7f","summary":"ruby-saml vulnerable to XPath injection","modified":"2025-01-14T22:26:10.295476Z","packages":[{"ecosystem":"RubyGems","name":"ruby-saml","purl":"pkg:gem/ruby-saml","ranges":["<1.0.0"],"fixed":["1.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}