{"cve":"CVE-2015-1866","nvd":{"published":"2017-09-20T18:29:00.673","modified":"2026-06-17T00:23:08.507","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in Ember.js 1.10.x before 1.10.1 and 1.11.x before 1.11.2.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2015/04/14/11","http://www.securityfocus.com/bid/74185","https://emberjs.com/blog/2015/04/14/security-and-bugfix-releases-ember-1-10-1-1-11-2-1-11-3.html","http://www.openwall.com/lists/oss-security/2015/04/14/11","http://www.securityfocus.com/bid/74185"],"products":["emberjs:ember.js"],"source":"nvd","synced_at":"2026-10-19T20:46:01.145313090+00:00"},"epss":{"cve":"CVE-2015-1866","score":0.0112,"percentile":0.66184,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mp78-r56v-45qc","url":"https://osv.dev/vulnerability/GHSA-mp78-r56v-45qc","summary":"ember-source vulnerable to Cross-site Scripting","modified":"2024-02-16T08:03:16.123580Z","packages":[{"ecosystem":"RubyGems","name":"ember-source","purl":"pkg:gem/ember-source","ranges":[">=1.10.0 <1.10.1"],"fixed":["1.10.1"]},{"ecosystem":"RubyGems","name":"ember-source","purl":"pkg:gem/ember-source","ranges":[">=1.11.0 <1.11.2"],"fixed":["1.11.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}