{"cve":"CVE-2014-7192","nvd":{"published":"2014-12-11T11:59:11.633","modified":"2026-06-17T00:14:32.410","status":"Modified","description":"Eval injection vulnerability in index.js in the syntax-error package before 1.1.1 for Node.js 0.10.x, as used in IBM Rational Application Developer and other products, allows remote attackers to execute arbitrary code via a crafted file.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-94"],"references":["http://www-01.ibm.com/support/docview.wss?uid=swg21690815","https://exchange.xforce.ibmcloud.com/vulnerabilities/96728","https://github.com/substack/node-syntax-error/commit/9aa4e66eb90ec595d2dba55e6f9c2dd9a668b309","https://nodesecurity.io/advisories/syntax-error-potential-script-injection","http://www-01.ibm.com/support/docview.wss?uid=swg21690815"],"products":["joyent:node.js"],"source":"nvd","synced_at":"2026-10-19T20:34:45.729216538+00:00"},"epss":{"cve":"CVE-2014-7192","score":0.13048,"percentile":0.96344,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5726-g6r9-5f22","url":"https://osv.dev/vulnerability/GHSA-5726-g6r9-5f22","summary":"Potential for Script Injection in syntax-error","modified":"2023-11-08T03:57:44.554728Z","packages":[{"ecosystem":"npm","name":"syntax-error","purl":"pkg:npm/syntax-error","ranges":["<1.1.1"],"fixed":["1.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}