{"cve":"CVE-2014-7191","nvd":{"published":"2014-10-19T01:55:21.560","modified":"2026-06-17T00:14:32.267","status":"Modified","description":"The qs module before 1.0.0 in Node.js does not call the compact function for array data, which allows remote attackers to cause a denial of service (memory consumption) by using a large index value to create a sparse array.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-399"],"references":["http://secunia.com/advisories/60026","http://secunia.com/advisories/62170","http://www-01.ibm.com/support/docview.wss?uid=swg21685987","http://www-01.ibm.com/support/docview.wss?uid=swg21687263","http://www-01.ibm.com/support/docview.wss?uid=swg21687928"],"products":["nodejs:node.js"],"source":"nvd","synced_at":"2026-10-19T20:34:04.196504363+00:00"},"epss":{"cve":"CVE-2014-7191","score":0.08309,"percentile":0.94932,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-jjv7-qpx3-h62q","url":"https://osv.dev/vulnerability/GHSA-jjv7-qpx3-h62q","summary":"Denial-of-Service Memory Exhaustion in qs","modified":"2023-11-08T03:57:44.492821Z","packages":[{"ecosystem":"npm","name":"qs","purl":"pkg:npm/qs","ranges":["<1.0.0"],"fixed":["1.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}