{"cve":"CVE-2014-6439","nvd":{"published":"2014-10-10T01:55:11.430","modified":"2026-06-17T00:13:06.730","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the CORS functionality in Elasticsearch before 1.4.0.Beta1 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://packetstormsecurity.com/files/128556/Elasticsearch-1.3.x-CORS-Issue.html","http://www.elasticsearch.org/blog/elasticsearch-1-4-0-beta-released/","http://www.securityfocus.com/archive/1/533602/100/0/threaded","http://www.securityfocus.com/bid/70233","https://www.elastic.co/community/security/"],"products":["elasticsearch:elasticsearch"],"source":"nvd","synced_at":"2026-10-19T20:34:04.196504363+00:00"},"epss":{"cve":"CVE-2014-6439","score":0.02023,"percentile":0.80971,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8699-m855-cwqf","url":"https://osv.dev/vulnerability/GHSA-8699-m855-cwqf","summary":"Cross-site scripting in Elasticsearch","modified":"2024-12-04T05:41:40.273745Z","packages":[{"ecosystem":"Maven","name":"org.elasticsearch:elasticsearch","purl":"pkg:maven/org.elasticsearch/elasticsearch","ranges":["<1.4.0.Beta1"],"fixed":["1.4.0.Beta1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}