{"cve":"CVE-2014-4326","nvd":{"published":"2014-07-22T14:55:09.550","modified":"2026-06-17T00:09:48.673","status":"Modified","description":"Elasticsearch Logstash 1.0.14 through 1.4.x before 1.4.2 allows remote attackers to execute arbitrary commands via a crafted event in (1) zabbix.rb or (2) nagios_nsca.rb in outputs/.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-78"],"references":["http://www.elasticsearch.org/blog/logstash-1-4-2/","http://www.securityfocus.com/archive/1/532841/100/0/threaded","https://www.elastic.co/community/security/","http://www.elasticsearch.org/blog/logstash-1-4-2/","http://www.securityfocus.com/archive/1/532841/100/0/threaded"],"products":["elastic:logstash"],"source":"nvd","synced_at":"2026-10-19T20:33:06.232976534+00:00"},"epss":{"cve":"CVE-2014-4326","score":0.03297,"percentile":0.88509,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8qhq-rq4j-8prj","url":"https://osv.dev/vulnerability/GHSA-8qhq-rq4j-8prj","summary":"Elasticsearch Logstash allows remote attackers to execute arbitrary commands","modified":"2025-04-16T17:18:13Z","packages":[{"ecosystem":"RubyGems","name":"logstash","purl":"pkg:gem/logstash","ranges":[">=1.0.14 <1.4.2"],"fixed":["1.4.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}