{"cve":"CVE-2014-3574","nvd":{"published":"2014-09-04T17:55:05.670","modified":"2026-06-17T00:08:32.377","status":"Modified","description":"Apache POI before 3.10.1 and 3.11.x before 3.11-beta2 allows remote attackers to cause a denial of service (CPU consumption and crash) via a crafted OOXML file, aka an XML Entity Expansion (XEE) attack.","cvss_v4":null,"cvss_v3":null,"cwes":[],"references":["http://poi.apache.org/changes.html","http://rhn.redhat.com/errata/RHSA-2014-1370.html","http://rhn.redhat.com/errata/RHSA-2014-1398.html","http://rhn.redhat.com/errata/RHSA-2014-1399.html","http://rhn.redhat.com/errata/RHSA-2014-1400.html"],"products":["apache:poi"],"source":"nvd","synced_at":"2026-10-19T20:34:04.196504363+00:00"},"epss":{"cve":"CVE-2014-3574","score":0.0711,"percentile":0.94243,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-5wfp-8643-c58x","url":"https://osv.dev/vulnerability/GHSA-5wfp-8643-c58x","summary":"Improper Input Validation in Apache POI","modified":"2024-12-08T05:37:27.312165Z","packages":[{"ecosystem":"Maven","name":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","ranges":["<3.10.1"],"fixed":["3.10.1"]},{"ecosystem":"Maven","name":"org.apache.poi:poi","purl":"pkg:maven/org.apache.poi/poi","ranges":[">=3.11-beta1 <3.11-beta2"],"fixed":["3.11-beta2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}