{"cve":"CVE-2014-3503","nvd":{"published":"2014-07-11T14:55:04.243","modified":"2026-06-17T00:08:19.177","status":"Modified","description":"Apache Syncope 1.1.x before 1.1.8 uses weak random values to generate passwords, which makes it easier for remote attackers to guess the password via a brute force attack.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-310"],"references":["http://packetstormsecurity.com/files/127375/Apache-Syncope-Insecure-Password-Generation.html","http://syncope.apache.org/security.html","http://www.securityfocus.com/archive/1/532669/100/0/threaded","http://www.securityfocus.com/bid/68431","http://packetstormsecurity.com/files/127375/Apache-Syncope-Insecure-Password-Generation.html"],"products":["apache:syncope"],"source":"nvd","synced_at":"2026-10-19T20:33:06.232976534+00:00"},"epss":{"cve":"CVE-2014-3503","score":0.06023,"percentile":0.93349,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-4c72-mrhf-23cg","url":"https://osv.dev/vulnerability/GHSA-4c72-mrhf-23cg","summary":"Apache Syncope uses a weak PNRG","modified":"2024-12-08T05:27:43.019566Z","packages":[{"ecosystem":"Maven","name":"org.apache.syncope:syncope","purl":"pkg:maven/org.apache.syncope/syncope","ranges":[">=1.1.0 <1.1.8"],"fixed":["1.1.8"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}