{"cve":"CVE-2014-3482","nvd":{"published":"2014-07-07T11:01:30.527","modified":"2026-06-17T00:08:16.863","status":"Modified","description":"SQL injection vulnerability in activerecord/lib/active_record/connection_adapters/postgresql_adapter.rb in the PostgreSQL adapter for Active Record in Ruby on Rails 2.x and 3.x before 3.2.19 allows remote attackers to execute arbitrary SQL commands by leveraging improper bitstring quoting.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-89"],"references":["http://openwall.com/lists/oss-security/2014/07/02/5","http://rhn.redhat.com/errata/RHSA-2014-0876.html","http://secunia.com/advisories/59973","http://secunia.com/advisories/60214","http://secunia.com/advisories/60763"],"products":["rubyonrails:rails","rubyonrails:ruby_on_rails"],"source":"nvd","synced_at":"2026-10-19T20:33:06.232976534+00:00"},"epss":{"cve":"CVE-2014-3482","score":0.04278,"percentile":0.91104,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-mhwp-qhpc-h3jm","url":"https://osv.dev/vulnerability/GHSA-mhwp-qhpc-h3jm","summary":"SQL Injection in Active Record","modified":"2025-03-31T17:38:53.400155Z","packages":[{"ecosystem":"RubyGems","name":"activerecord","purl":"pkg:gem/activerecord","ranges":[">=2.0.0 <3.2.19"],"fixed":["3.2.19"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}