{"cve":"CVE-2014-2686","nvd":{"published":"2020-01-09T13:15:10.413","modified":"2026-06-17T00:07:01.873","status":"Modified","description":"Ansible prior to 1.5.4 mishandles the evaluation of some strings.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","score":7.5},"cwes":["CWE-670"],"references":["https://groups.google.com/forum/#%21searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ","https://groups.google.com/forum/#%21searchin/ansible-project/1.5.4/ansible-project/MUQxiKwSQDc/id6aVaawVboJ"],"products":["redhat:ansible"],"source":"nvd","synced_at":"2026-10-19T21:01:01.339895972+00:00"},"epss":{"cve":"CVE-2014-2686","score":0.0119,"percentile":0.67962,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-49m5-2838-q2rv","url":"https://osv.dev/vulnerability/GHSA-49m5-2838-q2rv","summary":"Ansible unsafe evaluation of some strings","modified":"2025-02-19T05:41:35.824236Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<1.5.4"],"fixed":["1.5.4"]}]},{"id":"PYSEC-2020-198","url":"https://osv.dev/vulnerability/PYSEC-2020-198","summary":"","modified":"2026-06-10T17:00:05.535063338Z","packages":[{"ecosystem":"PyPI","name":"ansible","purl":"pkg:pypi/ansible","ranges":["<1.5.4"],"fixed":["1.5.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}