{"cve":"CVE-2014-2538","nvd":{"published":"2014-03-25T18:21:48.357","modified":"2026-06-17T00:06:47.103","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in lib/rack/ssl.rb in the rack-ssl gem before 1.4.0 for Ruby allows remote attackers to inject arbitrary web script or HTML via a URI, which might not be properly handled by third-party adapters such as JRuby-Rack.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://lists.opensuse.org/opensuse-updates/2014-04/msg00032.html","http://secunia.com/advisories/57466","http://www.openwall.com/lists/oss-security/2014/03/19/20","http://www.securityfocus.com/bid/66314","https://github.com/josh/rack-ssl/commit/9d7d7300b907e496db68d89d07fbc2e0df0b487b"],"products":["joshua_peek:rack-ssl"],"source":"nvd","synced_at":"2026-10-19T20:32:06.812358378+00:00"},"epss":{"cve":"CVE-2014-2538","score":0.0219,"percentile":0.82435,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-v3rr-cph9-2g2q","url":"https://osv.dev/vulnerability/GHSA-v3rr-cph9-2g2q","summary":"rack-ssl Cross-site Scripting vulnerability","modified":"2025-04-13T23:39:16.021465Z","packages":[{"ecosystem":"RubyGems","name":"rack-ssl","purl":"pkg:gem/rack-ssl","ranges":["<1.4.0"],"fixed":["1.4.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}