{"cve":"CVE-2014-10066","nvd":{"published":"2018-05-31T20:29:00.317","modified":"2026-06-17T00:04:10.620","status":"Modified","description":"Versions less than 0.1.4 of the static file server module fancy-server are vulnerable to directory traversal. An attacker can provide input such as `../` to read files outside of the served directory.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","score":7.5},"cwes":["CWE-22"],"references":["https://nodesecurity.io/advisories/9","https://nodesecurity.io/advisories/9"],"products":["fancy-server_project:fancy-server"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2014-10066","score":0.01582,"percentile":0.75534,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-m273-wwfv-h6jp","url":"https://osv.dev/vulnerability/GHSA-m273-wwfv-h6jp","summary":"Directory Traversal in fancy-server","modified":"2023-11-08T03:57:33.652665Z","packages":[{"ecosystem":"npm","name":"fancy-server","purl":"pkg:npm/fancy-server","ranges":["<0.1.4"],"fixed":["0.1.4"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}