{"cve":"CVE-2014-10064","nvd":{"published":"2018-05-31T20:29:00.220","modified":"2026-06-17T00:04:10.407","status":"Modified","description":"The qs module before 1.0.0 does not have an option or default for specifying object depth and when parsing a string representing a deeply nested object will block the event loop for long periods of time. An attacker could leverage this to cause a temporary denial-of-service condition, for example, in a web application, other requests would not be processed while this blocking is occurring.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","score":7.5},"cwes":["CWE-399","CWE-400"],"references":["https://nodesecurity.io/advisories/28","https://nodesecurity.io/advisories/28"],"products":["qs_project:qs"],"source":"nvd","synced_at":"2026-10-19T20:50:40.212176939+00:00"},"epss":{"cve":"CVE-2014-10064","score":0.01377,"percentile":0.72087,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-f9cm-p3w6-xvr3","url":"https://osv.dev/vulnerability/GHSA-f9cm-p3w6-xvr3","summary":"Denial-of-Service Extended Event Loop Blocking in qs","modified":"2023-11-08T03:57:33.533771Z","packages":[{"ecosystem":"npm","name":"qs","purl":"pkg:npm/qs","ranges":["<1.0.0"],"fixed":["1.0.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}