{"cve":"CVE-2013-7452","nvd":{"published":"2017-01-23T21:59:00.207","modified":"2026-06-17T00:01:59.363","status":"Modified","description":"The validator module before 1.1.0 for Node.js allows remote attackers to bypass the cross-site scripting (XSS) filter via a crafted javascript URI.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2016/04/20/11","https://nodesecurity.io/advisories/41","http://www.openwall.com/lists/oss-security/2016/04/20/11","https://nodesecurity.io/advisories/41"],"products":["nodejs:node.js"],"source":"nvd","synced_at":"2026-10-19T20:41:25.729257544+00:00"},"epss":{"cve":"CVE-2013-7452","score":0.02041,"percentile":0.81148,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-rh6c-q938-3r9q","url":"https://osv.dev/vulnerability/GHSA-rh6c-q938-3r9q","summary":"Moderate severity vulnerability that affects validator","modified":"2023-11-08T03:57:29.425588Z","packages":[{"ecosystem":"npm","name":"validator","purl":"pkg:npm/validator","ranges":["<1.1.0"],"fixed":["1.1.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}