{"cve":"CVE-2013-6459","nvd":{"published":"2013-12-31T16:04:23.447","modified":"2026-06-17T00:00:32.077","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the will_paginate gem before 3.0.5 for Ruby allows remote attackers to inject arbitrary web script or HTML via vectors involving generated pagination links.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://secunia.com/advisories/56180","http://www.securityfocus.com/bid/64509","https://access.redhat.com/errata/RHSA-2018:0336","https://github.com/mislav/will_paginate/releases/tag/v3.0.5","http://secunia.com/advisories/56180"],"products":["mislav_marohnic:will_paginate"],"source":"nvd","synced_at":"2026-10-19T20:30:15.895642412+00:00"},"epss":{"cve":"CVE-2013-6459","score":0.02209,"percentile":0.82589,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-8r6h-7x9g-xmw9","url":"https://osv.dev/vulnerability/GHSA-8r6h-7x9g-xmw9","summary":"will_paginate Cross-site Scripting vulnerability","modified":"2024-11-30T05:28:05.502487Z","packages":[{"ecosystem":"RubyGems","name":"will_paginate","purl":"pkg:gem/will_paginate","ranges":["<3.0.5"],"fixed":["3.0.5"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}