{"cve":"CVE-2013-6416","nvd":{"published":"2013-12-07T00:55:03.740","modified":"2026-06-17T00:00:26.917","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the simple_format helper in actionpack/lib/action_view/helpers/text_helper.rb in Ruby on Rails 4.x before 4.0.2 allows remote attackers to inject arbitrary web script or HTML via a crafted HTML attribute.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released/","http://www.securityfocus.com/bid/64071","https://groups.google.com/forum/message/raw?msg=ruby-security-ann/5ZI1-H5OoIM/ZNq4FoR2GnIJ","http://weblog.rubyonrails.org/2013/12/3/Rails_3_2_16_and_4_0_2_have_been_released/","http://www.securityfocus.com/bid/64071"],"products":["rubyonrails:rails"],"source":"nvd","synced_at":"2026-10-19T20:30:15.895642412+00:00"},"epss":{"cve":"CVE-2013-6416","score":0.01963,"percentile":0.80344,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-w37c-q653-qg95","url":"https://osv.dev/vulnerability/GHSA-w37c-q653-qg95","summary":"actionpack Cross-site Scripting vulnerability","modified":"2024-12-03T06:02:44.626274Z","packages":[{"ecosystem":"RubyGems","name":"actionpack","purl":"pkg:gem/actionpack","ranges":[">=4.0.0 <4.0.2"],"fixed":["4.0.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}