{"cve":"CVE-2013-6348","nvd":{"published":"2013-11-02T21:55:04.630","modified":"2026-06-17T00:00:20.440","status":"Modified","description":"Multiple cross-site scripting (XSS) vulnerabilities in Apache Struts 2.3.15.3 allow remote attackers to inject arbitrary web script or HTML via the namespace parameter to (1) actionNames.action and (2) showConfig.action in config-browser/.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://en.wooyun.org/bugs/wooyun-2013-034?2592","http://osvdb.org/99047","http://osvdb.org/99048","http://packetstormsecurity.com/files/123805/Struts-2.3.15.3-Cross-Site-Scripting.html","http://seclists.org/fulldisclosure/2013/Oct/244"],"products":["apache:struts"],"source":"nvd","synced_at":"2026-10-19T20:30:15.895642412+00:00"},"epss":{"cve":"CVE-2013-6348","score":0.06125,"percentile":0.93444,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-3g8j-jj54-3vjg","url":"https://osv.dev/vulnerability/GHSA-3g8j-jj54-3vjg","summary":"Apache Struts is vulnerable to Cross-site Scripting","modified":"2024-12-08T05:25:36.547069Z","packages":[{"ecosystem":"Maven","name":"org.apache.struts:struts2-core","purl":"pkg:maven/org.apache.struts/struts2-core","ranges":["<2.3.16"],"fixed":["2.3.16"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}