{"cve":"CVE-2013-1812","nvd":{"published":"2013-12-12T18:55:10.663","modified":"2026-06-16T23:52:10.110","status":"Modified","description":"The ruby-openid gem before 2.2.2 for Ruby allows remote OpenID providers to cause a denial of service (CPU consumption) via (1) a large XRDS document or (2) an XML Entity Expansion (XEE) attack.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-399"],"references":["http://lists.fedoraproject.org/pipermail/package-announce/2013-November/120204.html","http://lists.fedoraproject.org/pipermail/package-announce/2013-November/120361.html","http://www.openwall.com/lists/oss-security/2013/03/03/8","https://bugzilla.redhat.com/show_bug.cgi?id=918134","https://github.com/openid/ruby-openid/blob/master/CHANGELOG.md"],"products":["fedoraproject:fedora","janrain:ruby-openid"],"source":"nvd","synced_at":"2026-10-19T20:30:15.895642412+00:00"},"epss":{"cve":"CVE-2013-1812","score":0.02132,"percentile":0.81987,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-6c8p-qphv-668v","url":"https://osv.dev/vulnerability/GHSA-6c8p-qphv-668v","summary":"Denial of service in ruby-openid","modified":"2024-12-05T05:43:55.233706Z","packages":[{"ecosystem":"RubyGems","name":"ruby-openid","purl":"pkg:gem/ruby-openid","ranges":["<2.2.2"],"fixed":["2.2.2"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}