{"cve":"CVE-2013-1655","nvd":{"published":"2013-03-20T16:55:01.807","modified":"2026-06-16T23:51:51.153","status":"Modified","description":"Puppet 2.7.x before 2.7.21 and 3.1.x before 3.1.1, when running Ruby 1.9.3 or later, allows remote attackers to execute arbitrary code via vectors related to \"serialized attributes.\"","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-20"],"references":["http://lists.opensuse.org/opensuse-security-announce/2013-04/msg00004.html","http://lists.opensuse.org/opensuse-updates/2013-04/msg00056.html","http://secunia.com/advisories/52596","http://ubuntu.com/usn/usn-1759-1","http://www.debian.org/security/2013/dsa-2643"],"products":["puppet:puppet","puppet:puppet_enterprise","puppetlabs:puppet"],"source":"nvd","synced_at":"2026-10-19T20:27:27.940201468+00:00"},"epss":{"cve":"CVE-2013-1655","score":0.04558,"percentile":0.91598,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-574q-fxfj-wv6h","url":"https://osv.dev/vulnerability/GHSA-574q-fxfj-wv6h","summary":"Puppet Improper Input Validation vulnerability","modified":"2024-11-29T05:41:52.534442Z","packages":[{"ecosystem":"RubyGems","name":"puppet","purl":"pkg:gem/puppet","ranges":[">=2.7.0 <2.7.21"],"fixed":["2.7.21"]},{"ecosystem":"RubyGems","name":"puppet","purl":"pkg:gem/puppet","ranges":[">=3.1.0 <3.1.1"],"fixed":["3.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}