{"cve":"CVE-2012-6708","nvd":{"published":"2018-01-18T23:29:00.213","modified":"2026-06-16T23:48:38.840","status":"Modified","description":"jQuery before 1.9.0 is vulnerable to Cross-site Scripting (XSS) attacks. The jQuery(strInput) function does not differentiate selectors from HTML in a reliable fashion. In vulnerable versions, jQuery determined whether the input was HTML by looking for the '<' character anywhere in the string, giving attackers more flexibility when attempting to construct a malicious payload. In fixed versions, jQuery only deems the input to be HTML if it explicitly starts with the '<' character, limiting exploitability only to attackers who can control the beginning of a string, which is far less common.","cvss_v4":null,"cvss_v3":{"version":"3.0","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00041.html","http://packetstormsecurity.com/files/153237/RetireJS-CORS-Issue-Script-Execution.html","http://packetstormsecurity.com/files/161972/Linksys-EA7500-2.0.8.194281-Cross-Site-Scripting.html","http://www.securityfocus.com/bid/102792","https://bugs.jquery.com/ticket/11290"],"products":["jquery:jquery"],"source":"nvd","synced_at":"2026-10-19T20:48:34.567387330+00:00"},"epss":{"cve":"CVE-2012-6708","score":0.08632,"percentile":0.95102,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-2pqj-h3vj-pqgw","url":"https://osv.dev/vulnerability/GHSA-2pqj-h3vj-pqgw","summary":"Cross-Site Scripting in jquery","modified":"2024-03-08T05:20:14.907785Z","packages":[{"ecosystem":"npm","name":"jquery","purl":"pkg:npm/jquery","ranges":["<1.9.0"],"fixed":["1.9.0"]},{"ecosystem":"Maven","name":"org.webjars.npm:jquery","purl":"pkg:maven/org.webjars.npm/jquery","ranges":["<1.9.0"],"fixed":["1.9.0"]},{"ecosystem":"NuGet","name":"jQuery","purl":"pkg:nuget/jQuery","ranges":["<1.9.0"],"fixed":["1.9.0"]},{"ecosystem":"RubyGems","name":"jquery-rails","purl":"pkg:gem/jquery-rails","ranges":["<2.2.0"],"fixed":["2.2.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}