{"cve":"CVE-2012-6662","nvd":{"published":"2014-11-24T16:59:01.993","modified":"2026-06-16T23:48:34.540","status":"Modified","description":"Cross-site scripting (XSS) vulnerability in the default content option in jquery.ui.tooltip.js in the Tooltip widget in jQuery UI before 1.10.0 allows remote attackers to inject arbitrary web script or HTML via the title attribute, which is not properly handled in the autocomplete combo box demo.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-79"],"references":["http://bugs.jqueryui.com/ticket/8859","http://bugs.jqueryui.com/ticket/8861","http://rhn.redhat.com/errata/RHSA-2015-0442.html","http://rhn.redhat.com/errata/RHSA-2015-1462.html","http://seclists.org/oss-sec/2014/q4/613"],"products":["jqueryui:jquery_ui","redhat:enterprise_linux_desktop","redhat:enterprise_linux_hpc_node","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"source":"nvd","synced_at":"2026-10-19T20:34:45.729216538+00:00"},"epss":{"cve":"CVE-2012-6662","score":0.07475,"percentile":0.94472,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-qqxp-xp9v-vvx6","url":"https://osv.dev/vulnerability/GHSA-qqxp-xp9v-vvx6","summary":"jquery-ui Tooltip widget vulnerable to XSS","modified":"2025-04-14T22:25:51.702749Z","packages":[{"ecosystem":"npm","name":"jquery-ui","purl":"pkg:npm/jquery-ui","ranges":["<1.10.0"],"fixed":["1.10.0"]},{"ecosystem":"RubyGems","name":"jquery-ui-rails","purl":"pkg:gem/jquery-ui-rails","ranges":["<4.0.0"],"fixed":["4.0.0"]},{"ecosystem":"Maven","name":"org.webjars.npm:jquery-ui","purl":"pkg:maven/org.webjars.npm/jquery-ui","ranges":["<1.10.0"],"fixed":["1.10.0"]},{"ecosystem":"NuGet","name":"jQuery.UI.Combined","purl":"pkg:nuget/jQuery.UI.Combined","ranges":["<1.10.0"],"fixed":["1.10.0"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}