{"cve":"CVE-2012-6134","nvd":{"published":"2013-04-09T20:55:01.600","modified":"2026-06-16T23:47:53.187","status":"Modified","description":"Cross-site request forgery (CSRF) vulnerability in the omniauth-oauth2 gem 1.1.1 and earlier for Ruby allows remote attackers to hijack the authentication of users for requests that modify session state.","cvss_v4":null,"cvss_v3":null,"cwes":["CWE-352"],"references":["http://rubysec.github.io/advisories/CVE-2012-6134/","http://seclists.org/oss-sec/2013/q1/304","https://gist.github.com/homakov/3673012","https://github.com/Shopify/omniauth-shopify-oauth2/pull/1","https://github.com/intridea/omniauth-oauth2/pull/25"],"products":["omniauth-oauth2_project:omniauth-oauth2"],"source":"nvd","synced_at":"2026-10-19T20:27:27.940201468+00:00"},"epss":{"cve":"CVE-2012-6134","score":0.01196,"percentile":0.68088,"date":"2026-10-31"},"kev":null,"osv":[{"id":"GHSA-fgmx-8h93-26fh","url":"https://osv.dev/vulnerability/GHSA-fgmx-8h93-26fh","summary":"omniauth-oauth2 Cross-Site Request Forgery vulnerability","modified":"2024-12-05T05:39:59.934310Z","packages":[{"ecosystem":"RubyGems","name":"omniauth-oauth2","purl":"pkg:gem/omniauth-oauth2","ranges":["<1.1.1"],"fixed":["1.1.1"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}