{"cve":"CVE-2012-4440","nvd":{"published":"2019-11-18T22:15:10.907","modified":"2026-06-16T23:45:06.250","status":"Modified","description":"Cross-site Scripting (XSS) in Jenkins main before 1.482 and LTS before 1.466.2 allows remote attackers to inject arbitrary web script or HTML in the Violations plugin.","cvss_v4":null,"cvss_v3":{"version":"3.1","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","score":6.1},"cwes":["CWE-79"],"references":["http://www.openwall.com/lists/oss-security/2012/09/21/2","https://security-tracker.debian.org/tracker/CVE-2012-4440","https://www.cloudbees.com/jenkins-security-advisory-2012-09-17","http://www.openwall.com/lists/oss-security/2012/09/21/2","https://security-tracker.debian.org/tracker/CVE-2012-4440"],"products":["jenkins:jenkins"],"source":"nvd","synced_at":"2026-10-19T20:59:25.448946135+00:00"},"epss":{"cve":"CVE-2012-4440","score":0.01867,"percentile":0.79306,"date":"2026-11-01"},"kev":null,"osv":[{"id":"GHSA-5qpv-27q3-6484","url":"https://osv.dev/vulnerability/GHSA-5qpv-27q3-6484","summary":"Jenkins Violation Plugin allows Cross-Site Scripting (XSS)","modified":"2025-03-12T16:27:11.755050Z","packages":[{"ecosystem":"Maven","name":"org.jenkins-ci.plugins:violations","purl":"pkg:maven/org.jenkins-ci.plugins/violations","ranges":["<0.7.11"],"fixed":["0.7.11"]}]}],"attribution":["This product uses the NVD API but is not endorsed or certified by the NVD.","EPSS scores: FIRST Exploit Prediction Scoring System, https://www.first.org/epss","Known exploited vulnerabilities: CISA Known Exploited Vulnerabilities Catalog, https://www.cisa.gov/known-exploited-vulnerabilities-catalog","Package advisories: OSV (https://osv.dev), from the GitHub Advisory Database, PyPA, Go, RustSec and other ecosystem databases, under CC-BY 4.0 or CC0","CVE records: the CVE Program's CVE List (https://www.cve.org), under its terms of use (https://www.cve.org/Legal/TermsOfUse). CVE is a registered trademark of The MITRE Corporation; this product is not affiliated with the CVE Program."]}